prodracing.com

Unofficial SCCA Production Racing Forum
It is currently Thu Mar 21, 2019 1:48 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 13 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: What did I screw up?!
PostPosted: Mon Feb 25, 2019 5:43 pm 
Offline

Joined: Wed Apr 27, 2011 7:33 am
Posts: 294
Limited prep 1275 engine, just built, great leak down numbers...SU carbs with AN size needles...race cam(don't remember the specs but from APT)...we can get it to start and roughly idle but the carbs will not take throttle and the front carb is spitting fuel/air mix back out...we have a miss in the engine...the rear carb appears to be functioning properly. Other than the fact that I assembled the engine - what did I do wrong? (We have checked for vacuum leaks and found none.) Thoughts?
Thanks
EZ


Top
 Profile  
 
PostPosted: Mon Feb 25, 2019 5:52 pm 
Offline

Joined: Mon Oct 14, 2002 6:08 pm
Posts: 640
Location: Raleigh, NC
Eric:

Call Max Fulton at Flying Circus English Cars in Durham, NC and talk him through your problem. He is the crew chief on a vintage MGB and knows SUs, etc.

Rick

_________________
#27 FP MGB
#27 FP Miata
#0 ChampCar TR6


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 1:46 am 
Offline

Joined: Wed Sep 23, 2015 5:57 pm
Posts: 23
Did you check your timing? It's easy to get the cam off a tooth.

_________________
Brian Frank
Mild Mannered Fiesta Driver


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 4:41 am 
Offline

Joined: Wed Apr 27, 2011 7:33 am
Posts: 294
Timing has been checked and is spot on. Will check plug wires on the dist cap and continue to look for a vacuum leak. Any other thoughts?? Race a Miata?? BMC's competition department isn't answering their phone...


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 4:58 am 
Offline
User avatar

Joined: Tue Nov 03, 2009 6:44 pm
Posts: 849
Someone left an old sock in the intake manifold?

No, seriously, you checked timing but was that ignition timing or cam timing? Did you "dial in" the cam so you know that it is spot on? A quick check IIRC is that the #1 intake is open .125" at TDC. Other than that are the carb pistons free? If you are talking about a distributer, are you running a stock ignition system?

_________________
#4 HP Midget
HP National Champion


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 5:28 am 
Offline

Joined: Sun Aug 18, 2002 6:52 pm
Posts: 2170
Location: Topeka, Kansas
Sounds like a cam timing issue to me.

_________________
jesseprathermotorsports.com


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 6:36 am 
Offline

Joined: Wed Apr 27, 2011 7:33 am
Posts: 294
Thank you - this is helpful.


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 7:12 am 
Offline

Joined: Tue Nov 17, 2009 11:17 am
Posts: 186
Double check the firing order.


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 7:29 am 
Offline

Joined: Wed Apr 27, 2011 7:33 am
Posts: 294
That suggestion is on the top of the list! (We were so tired from scratching our heads last night we didn't check it.....)


Top
 Profile  
 
PostPosted: Tue Feb 26, 2019 4:19 pm 
Offline

Joined: Wed Apr 27, 2011 7:33 am
Posts: 294
Well this is embarrassing....the jam nut on the number four valve , exhaust for cyl 2 backed completely off...readjusted and now it runs. Thanks for all your help, let the ridiculing begin!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ]  Go to page 1, 2  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group